Domestic and International US Dollar (USD) Deposit Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Feb 11, 2020 - 14:03 UTC
Investigating
We are currently experiencing delays with Domestic and International US Dollar (USD) deposits. We are investigating the issue with our funding partner and will provide any update as soon as we have further information.
Posted Feb 11, 2020 - 00:32 UTC
This incident affected: Fiat Currency Funding (US Dollar (USD) - Domestic, US Dollar (USD) - International).