Custody – Vault creation errors

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 21:31 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2025 - 21:22 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 28, 2025 - 21:17 UTC

Investigating

We are investigating an issue causing errors when creating new custody vaults. Some clients may experience failures when attempting to create a vault. Our teams are working to identify the cause and restore normal operation.
Posted Aug 28, 2025 - 19:04 UTC
This incident affected: Kraken Institutional (OTC, Custody User Interface).