Monero (XMR) Funding Delays
Incident Report for Kraken
Resolved
XMR Funding has been restored. We will continue to monitor the situation closely.
Posted 4 months ago. May 19, 2019 - 20:38 UTC
Investigating
We’ve received reports of delays in the processing of XMR deposits and withdrawals. Our engineering team is investigating the issue. We’ll provide an update as soon as we have more information.
Posted 4 months ago. May 19, 2019 - 17:38 UTC
This incident affected: Digital Currency Funding (Monero (XMR)).