British Pound (GBP) deposits from Barclays Bank Temporarily Unavailable

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 18:55 UTC

Identified

British Pound (GBP) deposits from Barclays Bank (via Plaid) are currently unavailable. Please use other available funding methods in the meantime. We apologize for the inconvenience and will provide any updates as soon as possible.
Posted Apr 03, 2025 - 16:16 UTC