Signup Page Issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 22:07 UTC
Investigating
We are receiving reports of clients receiving an error 500 message during the signup process. We're investigating the issue and are working towards a solution. We'll provide any updates as soon as they become available.
Posted Dec 16, 2019 - 14:54 UTC
This incident affected: Website.