Signature and Signet Deposits and Withdrawals.
Incident Report for Kraken
Resolved
Signature and Signet deposits and withdrawals have permanently been discontinued for all clients.
Posted Apr 18, 2023 - 14:35 UTC
Update
Signature and Signet deposits and withdrawals have permanently been discontinued for all clients.
Posted Apr 05, 2023 - 00:18 UTC
Monitoring
Signature and Signet deposits and withdrawals are being processed as usual
Posted Mar 13, 2023 - 02:12 UTC