Delayed Historical Balance Data

Incident Report for Kraken

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 08, 2026 - 08:57 UTC

Investigating

We are currently investigating an issue affecting historical balance visibility. Users may see outdated hourly and daily historical balance information. Our engineering teams are actively working to resolve the issue. We will provide updates as more information becomes available.
Posted Sep 08, 2026 - 06:29 UTC