The Siacoin (SC) is still undergoing maintenance, which has been extended until 11:00 UTC. Deposits and withdrawals will be unavailable - transfers made during this time will be processed shortly after the maintenance is complete. We will provide updates as necessary.
Posted Dec 13, 2024 - 07:21 UTC
Update
The Siacoin (SC) is still undergoing maintenance from 17:00 UTC today for approximately 12hrs. Deposits and withdrawals will be unavailable - transfers made during this time will be processed shortly after the maintenance is complete. We will provide updates as necessary.
Posted Dec 13, 2024 - 03:16 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 12, 2024 - 17:00 UTC
Scheduled
The Siacoin (SC) funding gateway will be undergoing maintenance from 17:00 UTC today for approximately 12hrs. Deposits and withdrawals will be unavailable - transfers made during this time will be processed shortly after the maintenance is complete. We will provide updates as necessary.
Posted Dec 12, 2024 - 15:50 UTC
This scheduled maintenance affected: Digital Currency Funding (Siacoin (SC)).