Neutron (NTRN) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 08:25 UTC
Update
Neutron chain has halted from a consensus failure. Neutron Team is working on a fix and we will provide updates as soon as they are available.
Posted Jan 14, 2025 - 09:00 UTC
Investigating
Neutron (NTRN) withdrawals and deposits are experiencing delays. We are investigating the issue and will inform you when we have information.
Posted Jan 14, 2025 - 08:45 UTC
This incident affected: Digital Currency Funding (Neutron (NTRN) - COSMOS SDK).