Banking Circle Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 16, 2025 - 11:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 16, 2025 - 10:05 UTC

Investigating

We have identified an issue with Banking Circle’s reporting systems. As a result, Euro (EUR) and Pound Sterling (GBP) deposits may experience some delays in processing. We are working diligently to resolve the issue and will keep you updated.
Posted May 16, 2025 - 08:37 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA, Pound Sterling (GBP) - Domestic).