Crypto Deposit Delays
Incident Report for Kraken
Resolved
The crypto deposit delay has been resolved and deposit times have returned to normal.
Posted Jan 02, 2018 - 00:27 UTC
Investigating
We are currently experiencing delays with deposits for several crypto currencies, including XBT, ETH, LTC, XRP, XLM and ZEC.
Posted Jan 01, 2018 - 19:24 UTC