Instant Buys & Recurring and Custom order delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 25, 2026 - 11:21 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 25, 2026 - 11:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted May 25, 2026 - 07:36 UTC

Update

A fix that has resolved the majority of affected cases has been implemented. A small number of cases remain under investigation and we will provide a further update once all cases are resolved.
Posted May 23, 2026 - 11:30 UTC

Identified

We are aware of some users reporting issues with Instant Buy, and Recurring and Custom orders. Our engineers are aware of the issue are are preparing a fix.
Posted May 21, 2026 - 19:45 UTC
This incident affected: Website, Kraken App, Kraken Pro App, Krak App, and Krak Card.