Connectivity Issues - Equities Onboarding

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 16:08 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 11, 2025 - 14:04 UTC

Investigating

We are investigating reports of issues with completing onboarding for Kraken Equities. Some clients may be unable to proceed past required verification steps. Our team is working to identify the cause and restore full functionality. We will provide updates as soon as more information becomes available.
Posted Jun 11, 2025 - 09:13 UTC
This incident affected: Equities.