Degraded Performance for Card and Apple Pay Purchases

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Feb 18, 2026 - 17:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 18, 2026 - 17:39 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 18, 2026 - 17:19 UTC

Investigating

We are currently investigating an issue impacting some clients attempting to complete purchases using card and Apple Pay on Kraken Mobile and Web. Affected users may see an error message and be unable to proceed with their transaction. We are actively investigating and will provide updates shortly.
Posted Feb 18, 2026 - 16:51 UTC
This incident affected: Website and Kraken App.