Website Navigation Issue

Incident Report for Kraken

Resolved

This incident has been resolved. If the issue persists, please contact our support at support.kraken.com.
Posted Nov 07, 2020 - 13:30 UTC

Investigating

Some clients have reported an issue with navigating on the website, as the tabs to navigate the site might not be displayed properly. We're aware of the issue and are working towards a solution. In the meantime, please try to use a different browser and/or delete your browser cookies and cache. We will provide any updates as soon as they become available.
Posted Nov 07, 2020 - 11:53 UTC
This incident affected: Website.