Historical Portfolio Balances Display Issue on Kraken Pro Web

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 13:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 12:40 UTC

Investigating

We are currently investigating an issue preventing historical portfolio balances from displaying correctly on the Kraken Pro website. We are actively working on a fix and will provide further updates as soon as possible.
Posted Jul 29, 2025 - 12:19 UTC
This incident affected: Website.