A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 13:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 13:20 UTC
Update
We’ve identified that the impact affecting Washington State (WA, USA) users is broader than initially shared. In addition to Kraken Earn allocation failures and Krak issues, Trading functionality is also impacted. Our teams continue to investigate and we’ll provide further updates as more information becomes available.
Posted Jul 18, 2025 - 10:48 UTC
Investigating
We are currently investigating an issue affecting users located in Washington State (WA, USA). The Krak interface is accessible, but all operations initiated by users in this region are currently failing. Additionally, Kraken Earn strategies may appear available, but allocation attempts are not completing successfully.
We are working to resolve the issue and will update as soon as we have more information.
Posted Jul 18, 2025 - 09:22 UTC
This incident affected: Website, Mobile Applications, and Krak.