Kraken Pro Web Orders Issue

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Oct 17, 2024 - 00:19 UTC

Investigating

We're currently investigating reports from clients that are unable to place orders via Kraken Pro Web. As a workaround, please use the Pro Mobile app. We will provide updates as we are able.
Posted Oct 16, 2024 - 17:39 UTC
This incident affected: Website.