Issue Adding BTC Withdrawal Addresses on Kraken Pro
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 20:57 UTC
Investigating
We're currently investigating an issue with adding BTC withdrawal addresses on the Kraken Pro app. As a workaround in the meantime, please use the Kraken web, Kraken Pro web, or Kraken mobile platforms. We will provide updates as we have them.
Posted Sep 27, 2024 - 18:57 UTC
This incident affected: Mobile Applications.