Email Delivery Issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 09:29 UTC

Monitoring

No additional email delays have been detected over the past several hours. We will continue to closely monitor the situation throughout the weekend.
Posted Jul 05, 2025 - 23:57 UTC

Investigating

We are aware of reports of degraded performance affecting email delivery. Clients may experience delays receiving emails related to account activation, withdrawals, security actions, and other automated notifications.
Posted Jul 04, 2025 - 23:05 UTC