Account Creation Issues.

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 26, 2026 - 14:02 UTC

Investigating

We are currently investigating an issue that causes errors while creating new account on Mobile Apps for around 5% attempts. Web services are not affected.
Posted Jun 25, 2026 - 10:58 UTC
This incident affected: Kraken Pro App and Krak App.