Bank Frick Deposit Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 20, 2023 - 17:54 UTC
Identified
EUR/USD/CHF/GBP deposits through Bank Frick only may be delayed at this time due to a technical issue on their end. All other funding methods, including Bank Frick EUR/USD/CHF/GBP withdrawals, are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Nov 20, 2023 - 12:36 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits).