MVB Gateway (USD): Transactions via Wire Transfer Delayed

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 30, 2023 - 20:58 UTC

Investigating

We're investigating an issue with the MVB (USD) funding gateway. Withdrawals & Deposits via wire transfer are currently delayed. We will provide any updates as soon as possible.
Posted Nov 30, 2023 - 17:01 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).