Funding Email Delivery Issues.
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted 2 months ago. May 04, 2019 - 15:07 UTC
Investigating
We are investigating reports of delays for the withdrawal address verification email. Please note support emails are not impacted. We’ll provide an update as soon as we have further information to provide.
Posted 2 months ago. May 04, 2019 - 07:13 UTC
This incident affected: Website.