Delays linking bank accounts via Plaid

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Apr 18, 2026 - 08:02 UTC

Identified

We've identified that the issue is related to our vendor, Plaid, and we’re actively monitoring their progress toward a resolution. At this time, the vast majority of clients using Plaid for funding remain unaffected.
Posted Apr 18, 2026 - 06:36 UTC

Investigating

We're investigating an issue with delays linking bank accounts via Plaid. We are working diligently to resolve the issue and will keep you updated.
Posted Apr 18, 2026 - 04:06 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).