Block Production on Peaq blockchain stalled.

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 22:40 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 23, 2026 - 19:47 UTC

Investigating

Peaq team informed on X that the block production is currently stalled. Withdrawals and deposits are delayed. We are observing the issue and will post updates here.
Posted Mar 23, 2026 - 15:21 UTC
This incident affected: Digital Currency Funding (PEAQ (PEAQ)).