New Australian Clients Unable to Signup to PayID
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 22, 2024 - 12:12 UTC
Identified
We are currently experiencing a technical issue impacting new PayID registrations. As a result, new clients will be unable to to register for PayID. However, as an alternative clients can continue to make deposits using regular Bank Transfer services, which remain unaffected.
Additionally, some withdrawals may be subject to delayed processing times.

We will continue to monitor the situation and provide updates as necessary.
Posted Nov 22, 2024 - 05:16 UTC
This incident affected: Payment Methods (Australian Dollar (AUD) - Domestic).