Mina (MINA) Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 02, 2021 - 20:37 UTC
Identified
We're investigating an issue with the Mina (MINA) funding gateway. Deposits and withdrawals are currently delayed. A fix has been provided by the Mina team, expected completion in 30 minutes. We will provide any updates as soon as possible.
Posted Jun 02, 2021 - 19:51 UTC
This incident affected: Digital Currency Funding (Mina (MINA)).