Cryptocurrency Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jun 09, 2020 - 01:53 UTC
Investigating
We are currently experiencing delays processing withdrawals for several cryptocurrencies including Bitcoin (XBT), Litecoin (LTC), and Ethereum (ETH). Our engineers are investigating the issue. We will provide any updates as soon as possible.
Posted Jun 08, 2020 - 23:58 UTC
This incident affected: Digital Currency Funding (Bitcoin (XBT), Ether (ETH), Litecoin (LTC), Bitcoin Cash (BCH)).