Degraded Performance - Pro Tier Verification Flow

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 28, 2025 - 11:09 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 28, 2025 - 09:47 UTC

Investigating

We are currently investigating an issue affecting the Pro tier verification flow for some users. Impacted users may encounter an infinite redirect when navigating to the Pro verification upgrade page. Workaround available: Users who are experiencing issues and are unable to proceed with Pro verification can contact our Support team for manual assistance while we work to resolve the issue. We will provide updates as more information becomes available.
Posted May 28, 2025 - 09:35 UTC
This incident affected: Website.