EUR SEPA and GBP FPS Withdrawals via OpenPayd delayed

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Oct 03, 2025 - 03:28 UTC

Update

We are continuing to investigate this issue.
Posted Oct 03, 2025 - 03:01 UTC

Investigating

EUR SEPA and GBP FPS withdrawals processed through our payment provider, OpenPayd, are currently experiencing delays. Our team is actively investigating the issue, and we will share further updates as soon as more information becomes available.
Posted Oct 03, 2025 - 02:44 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA, Pound Sterling (GBP) - Instant).