A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 22:38 UTC
Update
We are continuing to investigate the issue affecting connectivity and functionality across Kraken platforms. Clients may still experience problems with deposits, withdrawals, logging in, and viewing account information.
Posted Jul 09, 2025 - 22:24 UTC
Investigating
We previously observed signs of recovery, but the issue has reoccurred. Clients may again experience problems with deposits, withdrawals, viewing balances, or logging into Kraken platforms (Web and Mobile).
We have resumed active investigation. We will continue to post updates here as more information becomes available.
Posted Jul 09, 2025 - 21:45 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 21:27 UTC
Investigating
We are investigating reports of degraded performance across Kraken platforms, including the website, mobile apps, and API. Clients may experience errors when attempting to withdraw or deposit assets, view balances, or access certain account information.
We will provide further updates as soon as more information becomes available.
Posted Jul 09, 2025 - 20:43 UTC
This incident affected: Website and Mobile Applications.