Staking menu display issue
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Oct 12, 2020 - 18:53 UTC
Investigating
Some clients have reported issues with the Staking display menu.
Posted Oct 12, 2020 - 17:27 UTC
This incident affected: Staking (Bitcoin (XBT) - Off-chain, Cosmos (ATOM) - On-chain, Euro (EUR) - Off-chain, Polkadot (DOT) - On-chain, Tezos (XTZ) - On-chain, US Dollar (USD) - Off-chain).