Withdrawal Address Confirmation Email - Delivery Issues
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Jul 23, 2020 - 13:29 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We will continue to provide updates as necessary.
Posted Jul 23, 2020 - 13:19 UTC
Investigating
We are investigating reports of delays for the withdrawal address confirmation email. Please attempt to request the email again (after the expiration time has passed). We're investigating the issue and will provide any updates as soon as possible.
Posted Jul 23, 2020 - 08:56 UTC
This incident affected: Website.