Bank Frick Funding Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 20, 2024 - 16:21 UTC
Identified
We have identified an issue with Bank Frick.
Deposits and withdrawals for EUR (SEPA and SWIFT), USD (SWIFT), CAD (SWIFT), GBP (SWIFT), and CHF (SIC and SWIFT) may be delayed at this time. All other funding methods are operating normally. We are working diligently to resolve the issue and will keep you updated.
Posted Nov 20, 2024 - 12:51 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA, Euro (EUR) - Wire Transfer Deposits, US Dollar (USD) - International, Canadian Dollar (CAD) - International, Swiss Franc (CHF) - Domestic, Swiss Franc (CHF) - International, Pound Sterling (GBP) - International).