Connectivity Issues - MORPHO markets
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 12:32 UTC
Investigating
We are investigating reports from clients having difficulty to trade in the MORPHO/USD and MORPHO/EUR markets. We are working to resolve the issue and will update as soon as we have more information.
Posted Nov 21, 2024 - 11:37 UTC