Krak Card degraded performance

Incident Report for Kraken

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 25, 2026 - 21:38 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 25, 2026 - 20:10 UTC

Investigating

We are investigating an issue that prevents subset of clients from performing card actions like ordering, freezing, unfreezing, viewing limits etc. Transactions are not affected. Updates will be posted here.
Posted Feb 25, 2026 - 15:56 UTC
This incident affects: Krak Card.