EUR SEPA Deposits and Withdrawals Delay

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted May 08, 2023 - 12:58 UTC

Investigating

EUR Deposits and Withdrawals via the Clearjunction funding method is unavailable due to Clearjunction investigating an issue with their processing system
Posted May 08, 2023 - 01:53 UTC
This incident affected: Payment Methods (Euro (EUR) - SEPA).