Plaid USD funding delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 01:05 UTC

Identified

We are aware of an ongoing issue with our third-party provider, Plaid, that is causing delays for US clients initiating deposits or withdrawals via Plaid linked bank accounts. 

We are monitoring the situation and will provide updates as more information becomes available.
Posted Mar 09, 2026 - 22:30 UTC
This incident affected: Payment Methods (US Dollar (USD) - Instant).