Balance Display Issues

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 11, 2025 - 14:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 11, 2025 - 11:48 UTC

Update

We are continuing to investigate this issue.
Posted Nov 11, 2025 - 09:58 UTC

Investigating

We're investigating reports from some clients seeing inaccurately displayed balances in their account overview. Our engineering teams are actively investigating the issue. We will provide updates as more information becomes available.
Posted Nov 11, 2025 - 09:48 UTC
This incident affected: Website, Kraken App, Kraken Pro App and Kraken API (Embed).