Onboarding Issues for EEA clients on Mobile Apps.

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jun 10, 2026 - 17:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 10, 2026 - 17:41 UTC

Investigating

We are currently investigating an issue that causes Apps to freeze during Tax Number verification step for EEA clients. Web services are not affected.
Posted Jun 10, 2026 - 16:40 UTC
This incident affected: Kraken App, Kraken Pro App, and Krak App.