Maintenance - Funding pages
Incident Report for Kraken
Resolved
Maintenance on Funding and Verification pages is complete.
Posted Dec 16, 2017 - 03:09 UTC
Monitoring
We're currently doing maintenance on our Funding and Verification pages. We will provide an update when these pages are back up.
Posted Dec 16, 2017 - 00:02 UTC