Transaction Flow Problems affecting EU Clients

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 19:35 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 18, 2025 - 12:28 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 18, 2025 - 10:55 UTC

Investigating

We’re currently investigating an issue where EU clients might be unable to complete their transactions.
Affected users may encounter errors when clicking links in email notifications or when trying to proceed through the normal flow on Kraken platforms.

Our teams are actively working to identify and resolve the issue. We’ll provide an update here as soon as more information is available.
Posted Jul 18, 2025 - 10:18 UTC
This incident affected: Website.