Possible Delays in GBP Deposits via Banking Circle

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Nov 06, 2025 - 08:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 05, 2025 - 22:44 UTC

Investigating

We are investigating reports of possible delays in crediting GBP deposits made via Banking Circle and Plaid (GBP).

Deposits are still being received and will settle, but some clients may experience longer processing times before funds are available for trading.

Other deposit and withdrawal methods remain operational.
Posted Nov 05, 2025 - 21:22 UTC
This incident affected: Payment Methods (Pound Sterling (GBP) - Domestic, Pound Sterling (GBP) - Instant).