Customers Bank Withdrawal Delays
Incident Report for Kraken
Resolved
This incident has been resolved.
Posted Aug 14, 2024 - 16:05 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2024 - 02:19 UTC
Investigating
We are currently investigating an issue with withdrawal delays through Customers Bank. Deposits remain unaffected. We will provide updates as soon as possible.
Posted Aug 13, 2024 - 22:15 UTC
This incident affected: Payment Methods (US Dollar (USD) - Domestic).