Issues with Support Center login

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Oct 19, 2025 - 18:33 UTC

Investigating

We are aware of intermittent issues in accessing support.kraken.com. When trying to sign in users are getting redirected to support.kraken.com page. We are investigating the cause and will provide information once it is available.
Posted Oct 19, 2025 - 16:22 UTC
This incident affected: Support.