Intermittent Issues With Document Verification

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 20:01 UTC

Identified

We are investigating intermittent issues affecting document verification during account onboarding. Some clients may experience errors or delays when completing identity verification. Our teams are working to resolve the issue, and we will provide updates as more information becomes available.
Posted Jan 15, 2026 - 16:31 UTC