Order History – Delayed visibility for some closed orders

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 23:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 07, 2026 - 03:41 UTC

Identified

We are aware of an issue where some closed orders may not be visible in order history.

Our team has identified the cause and a fix is in progress.

We will provide updates as the situation progresses.
Posted Mar 06, 2026 - 19:05 UTC