Stellar Lumens (XLM) Funding Delays.
Incident Report for Kraken
Resolved
XLM Funding has been restored. We will continue to monitor the situation closely.
Posted 2 months ago. May 03, 2019 - 07:24 UTC
Investigating
We’re investigating reports of delays in processing XLM deposits and withdrawals. We’ll provide an update as soon as we have any more information to provide.
Posted 2 months ago. May 03, 2019 - 03:12 UTC
This incident affected: Digital Currency Funding (Stellar Lumens (XLM)).