Cosmos (ATOM) Funding Delays

Incident Report for Kraken

Resolved

This incident has been resolved.
Posted Dec 02, 2023 - 02:48 UTC

Identified

Cosmos (ATOM) network is currently experiencing higher than usual network congestion. Deposits and withdrawals may be delayed at this time. All other funding methods are operating normally. We are actively monitoring the network and will keep you updated.
Posted Dec 01, 2023 - 20:41 UTC
This incident affected: Digital Currency Funding (Cosmos (ATOM)).